1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice
  3. What happens when the XF 2.0 is out? See the discussion here: http://www.sonnb.com/threads/what-happens-when-xf-2-0-is-out.1146/
    Dismiss Notice

BUG Video Plays Only Audio

Discussion in 'XenGallery - Video Upload' started by hollosch, Jun 6, 2018.

  1. hollosch

    hollosch Authorized Member Authorized

  2. hollosch

    hollosch Authorized Member Authorized

    Update, on Firefox and Edge browser nothing works... :-(
     
  3. sonnb

    sonnb Administrator Staff Member

  4. hollosch

    hollosch Authorized Member Authorized

    with vlan-Player it works.
    Windows Player has to download an MPEG-2 Codec. Is the problem at the uploaded file?
    how can i fix this on server-side?

    regards

    ScreenShot-2018-Jun-09-920-AM.png
     
  5. sonnb

    sonnb Administrator Staff Member

    Normally with PC video player it will works fine. It is normal as depending on the player codecs. Please try to run ffmpeg -formats to see list of supported codecs.

    In the code I convert to audio codec from the current to AAC and convert the video to the H264 codec. The web players also try to benefit from the browser embedded HTML5 video player. Therefore I recommend to upload only supported HTML5 file formats to make it works in all cases.
     
  6. sonnb

    sonnb Administrator Staff Member

    Can you also share me a link to the original video file so I can have a look on it?
     

Share This Page