1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice
  3. What happens when the XF 2.0 is out? See the discussion here: http://www.sonnb.com/threads/what-happens-when-xf-2-0-is-out.1146/
    Dismiss Notice

Sonnb - Xengallery (xenforo Gallery) [paid] 2.6.8

Modern Albums with Photos and Videos gallery for your XenForo

  1. NaNa

    NaNa Member

    Dear Sonnb, I have not changed anythig, but after the update the watermark dissapeared from my galery.
    It is enabled in the admin... What should I do?
    Thank you
     
  2. sonnb

    sonnb Administrator Staff Member

    Dear NaNa,

    Do you mean when you upload new photos, the watermark is not applied?
     
  3. NaNa

    NaNa Member

    Dear Sonnb,
    The watermark have disappeared from all the photoes, and not seen on the new ones eighter.
     
  4. sonnb

    sonnb Administrator Staff Member

    I believe you rebuild photos after upgrade? Are you on the latest version yet? If possible, please share me an admin login via conversation so I can have a look on this faster.
     
  5. NaNa

    NaNa Member

    Yes, I have rebuilt the photoes.
    How can I check if it is the latest version? (My webmester is unreachable now.)
     
  6. sonnb

    sonnb Administrator Staff Member

    The only way is check the version in admin section. I remember there is an issue with watermark in older version which return false even there is a watermark need to be applied.
     
  7. NaNa

    NaNa Member

    Ok, I have found it. 2.4.1. Than it is not the latest version...
     
  8. sonnb

    sonnb Administrator Staff Member

    Please rebuild after install to apply the watermark again.
     
  9. NaNa

    NaNa Member

    OK. Thanks
     
  10. oloman

    oloman New Member

    Hello,

    I'd like to add under the avatar (in posts) un button/link who go directly yo the member's gallery. The is a easy way to do that?

    Best regards
     
  11. sonnb

    sonnb Administrator Staff Member

    Yes, it is easy. You just need to edit the template "message_user_info" put your desired button under
    For example:
    Code:
    <em class="userBanner bannerStaff" style="margin-top: 5px; margin-left: 0px; margin-right: 0px;"><a href="{xen:link gallery/authors, $user}" style="font-weight: bold;">User gallery</a></em>
     
    zoldos likes this.
  12. oloman

    oloman New Member

    Thanks it works fine:)
     
  13. zoldos

    zoldos Authorized Member Authorized

    I found a bug when someone posts a Youtube video link inside a picture comment. Please see the screenshot:

    bug1.jpg

    I have recently removed Video Upload add-on. Not sure if that has anything to do with it. Thanks!
     
  14. sonnb

    sonnb Administrator Staff Member

    Make sure you have this option checked:
    upload_2015-9-8_0-26-36.png
     
    zoldos likes this.
  15. zoldos

    zoldos Authorized Member Authorized

    Okay thanks! :)
     
  16. egerci

    egerci Authorized Member Authorized

    Hello Sonnb,

    I have a problem with album per page settings.

    If I set it low as 20 album per page, sometimes visitors see noting some pages.
    For example :
    there are 100 albums total
    Our albums per page setting is 20
    If you are an admin, you can see all of albums in 5 pages (no problem)
    If all of albums's privacy options is everyone, all visitors can see all of albums in 5 pages (no problem)
    If last created /edited 10 albums' privacy options is "registered user" , visitors only see 10 albums at first pages. if privacy options is "only me", registered users also see 10 albums at first pages.

    So, My sites' most of the albums' privacy options are "People Following Me" "People I Followed" and "Registered Users" Because of this visitors and sometimes registered users see empty list when they are browsing albums.

    For example at my album list pages's 5th page:
    I see 20 albums at 5th page (as an admin)
    I see 6 albums at 5th page (as a normal registered user)
    I see nothing at 5th page. (as a normal visitors)
    upload_2015-9-9_16-24-2.png

    I think, calculating album per page and showing albums in albums list page, addon have to consider privacy options.

    Thanks,
     
  17. sonnb

    sonnb Administrator Staff Member

    You are right. But it is not possible to know which album is accessible by the current user when querying the albums. There is a workaround for this which is enable the infinity scrolling, users will not know about the contents per page (even empty). I will note this as a known case and to see what we need to do to solve it.
     
    egerci likes this.
  18. bkrox

    bkrox Authorized Member Authorized

    Hi @sonnb ,

    I face the issue with Son Xen Gallery 2.4.1 on Xenforo 1.4.8. When I disable Son Xen Gallery, I can use Xenporta Feature Slide normally without any issue. But when I enable Xen Gallery add-on, Feature Slide of Xenporta has some issues:
    - Paper Bullet is not in the right place. Normally, it should be in the center.
    - When I click on the title or picture in the Feature Slide, it does not bring me to its url which it normally should do.
    Feature_Slide_Xenporta.JPG

    Please help check and fix it.
    Thanks!
     
  19. sonnb

    sonnb Administrator Staff Member

    Please open the template "sonnb_xengallery_bxslider.css"
    Find:
    Code:
    .bx-wrapper .bx-pager,
    .bx-wrapper .bx-controls-auto {
      position: absolute;
      bottom: -30px;
      width: 100%;
    }
    Change to:
    Code:
    .bx-wrapper .bx-pager,
    .bx-wrapper .bx-controls-auto {
      position: absolute;
      width: 100%;
    }
    Find:
    Code:
    .bx-wrapper .bx-pager {
      text-align: center;
      font-size: .85em;
      font-family: Arial;
      font-weight: bold;
      color: #666;
      padding-top: 20px;
    }
    Change to:
    Code:
    .bx-wrapper .bx-pager {
      text-align: center;
      font-size: .85em;
      font-family: Arial;
      font-weight: bold;
      color: #666;
    }
     
    whynot likes this.
  20. bkrox

    bkrox Authorized Member Authorized

    Thank you @sonnb . It works.
     

Share This Page